<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8"><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<title>Rick Houser: They have never liked me | The Clermont Sun</title>

<!-- The SEO Framework by Sybre Waaijer -->
<meta name="description" content="I have always stated just how much I loved growing up a farm boy and living out in the country. I have felt that John Denver&rsquo;s song &ldquo;Thank God I&rsquo;m a Country Boy&rdquo;&#8230;" />
<meta property="og:image" content="https://s25452.pcdn.co/wp-content/uploads/2018/03/Houserjpg-300x214.jpg" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Rick Houser: They have never liked me | The Clermont Sun" />
<meta property="og:description" content="I have always stated just how much I loved growing up a farm boy and living out in the country. I have felt that John Denver&rsquo;s song &ldquo;Thank God I&rsquo;m a Country Boy&rdquo; was my theme song. Now that spring has&#8230;" />
<meta property="og:url" content="https://www.clermontsun.com/2021/04/15/rick-houser-they-have-never-liked-me" />
<meta property="og:site_name" content="The Clermont Sun" />
<meta property="article:publisher" content="https://www.facebook.com/clermontsun" />
<meta property="article:published_time" content="2021-04-15T15:16+00:00" />
<meta property="article:modified_time" content="2021-04-15T15:16+00:00" />
<meta property="og:updated_time" content="2021-04-15T15:16+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@clermontsun" />
<meta name="twitter:title" content="Rick Houser: They have never liked me | The Clermont Sun" />
<meta name="twitter:description" content="I have always stated just how much I loved growing up a farm boy and living out in the country. I have felt that John Denver&rsquo;s song &ldquo;Thank God I&rsquo;m a Country Boy&rdquo; was my theme song. Now that spring has&#8230;" />
<meta name="twitter:image" content="https://s25452.pcdn.co/wp-content/uploads/2018/03/Houserjpg-300x214.jpg" />
<link rel="canonical" href="https://www.clermontsun.com/2021/04/15/rick-houser-they-have-never-liked-me" />
<script type="application/ld+json">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.clermontsun.com/","name":"The Clermont Sun"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.clermontsun.com/category/opinion","name":"Opinion"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.clermontsun.com/2021/04/15/rick-houser-they-have-never-liked-me","name":"Rick Houser: They have never liked me"}}]}</script>
<!-- / The SEO Framework by Sybre Waaijer | 3.27ms meta | 8.64ms boot -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Clermont Sun &raquo; Feed" href="https://www.clermontsun.com/feed" />
<link rel="alternate" type="application/rss+xml" title="The Clermont Sun &raquo; Comments Feed" href="https://www.clermontsun.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="The Clermont Sun &raquo; Rick Houser: They have never liked me Comments Feed" href="https://www.clermontsun.com/2021/04/15/rick-houser-they-have-never-liked-me/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s25452.pcdn.co\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.7"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://s25452.pcdn.co/wp-includes/css/dist/block-library/style.min.css?ver=5.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='megamenu-css'  href='https://s25452.pcdn.co/wp-content/uploads/maxmegamenu/style.css?ver=cd8d18' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://s25452.pcdn.co/wp-includes/css/dashicons.min.css?ver=5.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://s25452.pcdn.co/wp-content/themes/mh-magazine/style.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://s25452.pcdn.co/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:300,400,400italic,600,700' type='text/css' media='all' />
<script type='text/javascript' src='https://s25452.pcdn.co/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://s25452.pcdn.co/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://s25452.pcdn.co/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.3'></script>
<link rel='https://api.w.org/' href='https://www.clermontsun.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.clermontsun.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s25452.pcdn.co/wp-includes/wlwmanifest.xml" /> 
<link rel="alternate" type="application/json+oembed" href="https://www.clermontsun.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.clermontsun.com%2F2021%2F04%2F15%2Frick-houser-they-have-never-liked-me" />
<link rel="alternate" type="text/xml+oembed" href="https://www.clermontsun.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.clermontsun.com%2F2021%2F04%2F15%2Frick-houser-they-have-never-liked-me&#038;format=xml" />
<!--[if lt IE 9]>
<script src="https://s25452.pcdn.co/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<link rel="amphtml" href="https://www.clermontsun.com/2021/04/15/rick-houser-they-have-never-liked-me/amp">		<style type="text/css" id="wp-custom-css">
			
@media only screen and (max-width: 600px) {
	div.adblade-dyna.zone-13366 {
		display: none;
	}
}		</style>
		<style type="text/css">/** Mega Menu CSS: fs **/</style>
</head>
<body data-rsssl=1 id="mh-mobile" class="post-template-default single single-post postid-89552 single-format-standard wp-custom-logo mega-menu-mh-main-nav mh-boxed-layout mh-right-sb mh-loop-layout1 mh-widget-layout1" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<aside class="mh-container mh-header-widget-1">
<div id="custom_html-15" class="widget_text mh-widget mh-header-1 widget_custom_html"><div class="textwidget custom-html-widget"><script> (function(){var l=function(){if (document.readyState && /loading/.test(document.readyState)){return setTimeout(l, 10);} if (!top._liqwid_loaded){top._liqwid_loaded=true; return setTimeout(l, 10);} var s=document.createElement("script"), x=top.document.getElementsByTagName('script')[0]; s.setAttribute('async', 'true'); s.setAttribute('src','https://liqwid.net/?key=2B69-A3AA-AFFC-D516&u='+encodeURIComponent(top.location.href)+'&cb='+Date.now()+'-'+Math.floor(Math.random()*1000001)); x.parentNode.insertBefore(s,x);};l();})(); </script>
</div></div><div id="custom_html-23" class="widget_text mh-widget mh-header-1 widget_custom_html"><div class="textwidget custom-html-widget"><!---ins data-revive-zoneid="364" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>---></div></div></aside>
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
	<div class="mh-preheader">
    	<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-top-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-header-menu-container"><ul id="menu-header-menu" class="menu"><li id="menu-item-79720" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-79720"><a href="https://www.clermontsun.com/subscribe"><font size="+2">Subscribe</font></a></li>
<li id="menu-item-79722" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79722"><a href="https://www.clermontsun.com/category/special-publications">Special Publications</a></li>
<li id="menu-item-79721" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79721"><a href="https://www.clermontsun.com/category/legal-notices">Public Notices</a></li>
<li id="menu-item-81095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-81095"><a href="https://www.clermontsun.com/rack-locations">Rack Locations</a></li>
<li id="menu-item-80115" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80115"><a href="https://www.clermontsun.com/games">Games</a></li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-top-right mh-col-1-3 clearfix">
											<nav class="mh-social-icons mh-social-nav mh-social-nav-top clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-social-container"><ul id="menu-social" class="menu"><li id="menu-item-79701" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79701"><a href="https://www.facebook.com/clermontsun/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-79702" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-79702"><a href="https://twitter.com/clermontsun/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
</ul></div>						</nav>
									</div>
					</div>
	</div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<div class="mh-header-columns mh-row clearfix">
<div class="mh-col-1-3 mh-site-identity">
<div class="mh-site-logo" role="banner" itemscope="itemscope" itemtype="http://schema.org/Brand">
<a href="https://www.clermontsun.com/" class="custom-logo-link" rel="home"><img width="263" height="85" src="https://s25452.pcdn.co/wp-content/uploads/2018/02/cscmlogo.png" class="custom-logo" alt="The Clermont Sun" /></a></div>
</div>
<aside class="mh-col-2-3 mh-header-widget-2">
<div id="custom_html-8" class="widget_text mh-widget mh-header-2 widget_custom_html"><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="253" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>---></div></div></aside>
</div>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div id="mega-menu-wrap-mh_main_nav" class="mega-menu-wrap"><div class="mega-menu-toggle"><div class="mega-toggle-blocks-left"></div><div class="mega-toggle-blocks-center"></div><div class="mega-toggle-blocks-right"><div class='mega-toggle-block mega-menu-toggle-block mega-toggle-block-1' id='mega-toggle-block-1' tabindex='0'><span class='mega-toggle-label' role='button' aria-expanded='false'><span class='mega-toggle-label-closed'>MENU</span><span class='mega-toggle-label-open'>MENU</span></span></div></div></div><ul id="mega-menu-mh_main_nav" class="mega-menu max-mega-menu mega-menu-horizontal mega-no-js" data-event="hover_intent" data-effect="fade_up" data-effect-speed="200" data-effect-mobile="disabled" data-effect-speed-mobile="0" data-mobile-force-width="false" data-second-click="go" data-document-click="collapse" data-vertical-behaviour="standard" data-breakpoint="600" data-unbind="true" data-mobile-state="collapse_all" data-hover-intent-timeout="300" data-hover-intent-interval="100"><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-align-bottom-left mega-menu-flyout mega-menu-item-79621' id='mega-menu-item-79621'><a class="mega-menu-link" href="/" tabindex="0">Home</a></li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-79622' id='mega-menu-item-79622'><a class="mega-menu-link" href="https://www.clermontsun.com/category/news" aria-haspopup="true" aria-expanded="false" tabindex="0">News<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-79659' id='mega-menu-item-79659'><a class="mega-menu-link" href="https://www.clermontsun.com/weather">Weather</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-align-bottom-left mega-menu-flyout mega-menu-item-79623' id='mega-menu-item-79623'><a class="mega-menu-link" href="https://www.clermontsun.com/category/community" tabindex="0">Community</a></li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-current-post-ancestor mega-current-menu-parent mega-current-post-parent mega-align-bottom-left mega-menu-flyout mega-menu-item-79625' id='mega-menu-item-79625'><a class="mega-menu-link" href="https://www.clermontsun.com/category/opinion" tabindex="0">Opinion</a></li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-menu-item-has-children mega-align-bottom-left mega-menu-flyout mega-menu-item-79624' id='mega-menu-item-79624'><a class="mega-menu-link" href="https://www.clermontsun.com/category/sports" aria-haspopup="true" aria-expanded="false" tabindex="0">Sports<span class="mega-indicator"></span></a>
<ul class="mega-sub-menu">
<li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-menu-item-80513' id='mega-menu-item-80513'><a class="mega-menu-link" href="https://www.clermontsun.com/athletes-of-the-week">Athletes of the Week</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-83810' id='mega-menu-item-83810'><a class="mega-menu-link" href="https://pro32.ap.org/clermontsun">Pro Football</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-83811' id='mega-menu-item-83811'><a class="mega-menu-link" href="https://racing.ap.org/clermontsun">Auto Racing</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-83812' id='mega-menu-item-83812'><a class="mega-menu-link" href="https://collegebasketball.ap.org/clermontsun">College Basketball</a></li><li class='mega-menu-item mega-menu-item-type-custom mega-menu-item-object-custom mega-menu-item-83813' id='mega-menu-item-83813'><a class="mega-menu-link" href="https://collegefootball.ap.org/clermontsun">College Football</a></li></ul>
</li><li class='mega-menu-item mega-menu-item-type-taxonomy mega-menu-item-object-category mega-align-bottom-left mega-menu-flyout mega-menu-item-79626' id='mega-menu-item-79626'><a class="mega-menu-link" href="https://www.clermontsun.com/category/obituaries" tabindex="0">Obituaries</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-align-bottom-left mega-menu-flyout mega-menu-item-79719' id='mega-menu-item-79719'><a class="mega-menu-link" href="https://www.clermontsun.com/calendar" tabindex="0">Calendar</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-align-bottom-left mega-menu-flyout mega-menu-item-79628' id='mega-menu-item-79628'><a class="mega-menu-link" href="https://www.clermontsun.com/class" tabindex="0">Classifieds</a></li><li class='mega-menu-item mega-menu-item-type-post_type mega-menu-item-object-page mega-align-bottom-left mega-menu-flyout mega-menu-item-81872' id='mega-menu-item-81872'><a class="mega-menu-link" href="https://www.clermontsun.com/contact" tabindex="0">Contact</a></li></ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<div class="mh-header-ticker mh-header-ticker-bottom">
							<div class="mh-ticker-bottom">
			<div class="mh-ticker-title mh-ticker-title-bottom">
			News Ticker<i class="fa fa-chevron-right"></i>		</div>
		<div class="mh-ticker-content mh-ticker-content-bottom">
		<ul id="mh-ticker-loop-bottom">				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.clermontsun.com/2021/04/15/jennifer-lake-low-income-older-adults-need-access-to-fresh-produce-farmers-market-program-provides-it" title="Jennifer Lake: Low-income older adults need access to fresh produce; farmers’ market program provides it">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ April 15, 2021 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Jennifer Lake: Low-income older adults need access to fresh produce; farmers’ market program provides it						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Opinion							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.clermontsun.com/2021/04/15/john-plahovinsak-surveys-prove-vas-quality-medical-health-care-improves" title="John Plahovinsak: Surveys prove VA’s quality medical health care improves">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ April 15, 2021 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							John Plahovinsak: Surveys prove VA’s quality medical health care improves						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Opinion							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.clermontsun.com/2021/04/15/sen-sherrod-brown-allowing-more-ohio-workers-to-earn-overtime-pay" title="Sen. Sherrod Brown: Allowing more Ohio workers to earn overtime pay">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ April 15, 2021 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Sen. Sherrod Brown: Allowing more Ohio workers to earn overtime pay						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Opinion							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.clermontsun.com/2021/04/15/sen-rob-portman-stopping-the-crisis-at-the-border" title="Sen. Rob Portman: Stopping the crisis at the border">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ April 15, 2021 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Sen. Rob Portman: Stopping the crisis at the border						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Opinion							</span>
											</a>
				</li>				<li class="mh-ticker-item mh-ticker-item-bottom">
					<a href="https://www.clermontsun.com/2021/04/15/marc-hoover-the-disappearances-of-felipe-santos-and-terrance-williams" title="Marc Hoover: The disappearances of Felipe Santos and Terrance Williams">
						<span class="mh-ticker-item-date mh-ticker-item-date-bottom">
                        	[ April 15, 2021 ]                        </span>
						<span class="mh-ticker-item-title mh-ticker-item-title-bottom">
							Marc Hoover: The disappearances of Felipe Santos and Terrance Williams						</span>
													<span class="mh-ticker-item-cat mh-ticker-item-cat-bottom">
								<i class="fa fa-caret-right"></i>
																Opinion							</span>
											</a>
				</li>		</ul>
	</div>
</div>						</div>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<aside class="mh-header-search mh-header-search-bottom">
							<form role="search" method="get" class="search-form" action="https://www.clermontsun.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>						</aside>
									</div>
					</div>
	</div>
<div class="mh-wrapper clearfix">
	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content" role="main" itemprop="mainContentOfPage"><nav class="mh-breadcrumb"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.clermontsun.com" itemprop="url"><span itemprop="title">Home</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.clermontsun.com/category/opinion" itemprop="url"><span itemprop="title">Opinion</span></a></span><span class="mh-breadcrumb-delimiter"><i class="fa fa-angle-right"></i></span>Rick Houser: They have never liked me</nav>


<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.clermontsun.com/2021/04/15/rick-houser-they-have-never-liked-me"
  },
  "headline": "Rick Houser: They have never liked me",
     "datePublished": "2021-04-15T11:16:09-04:00",
  "dateModified": "2021-04-15T11:16:09-04:00",
  "author": {
    "@type": "Person",
		"name": "Staff Reports"
	  },
   "publisher": {
    "@type": "Organization",
    "name": "The Clermont Sun",
    "logo": {
      "@type": "ImageObject",
      "url": "/wp-content/uploads/2018/02/clermontlogo.png"
    }
  },
  "description": "I have always stated just how much I loved growing up a farm boy and living out in the country. I have felt that John Denver’s song “Thank God I’m a Country Boy” was my [...]"
}
</script>
<style>
.neFileBlock{
	display:none;
}
.metaInfo{
	display:none;
}
.entry-thumbnail img {
width: auto !important;
max-height: 400px;
}
.factbox{ 
	float:left; 
	width:190px; 
	margin:7px; 
	background-color:#f5f5f5; 
	padding:5px; 
	box-shadow: 0 10px 16px 0 rgba(0,0,0,0.2),0 6px 20px 0 rgba(0,0,0,0.19);
}
.map{ 
	float:left; 
	width:200px; 
	margin:7px; 
}
.kicker{
	font-style:italic;
}
.pullquote {
    float: left;
    width: 190px;
    background: #f5f5f5;
    font-weight: bold;
    padding: 5px;
    margin: 0 5px 5px 0;
	font-size:18px;
}
.extraBox{
	float:left; 
	width:200px;  
	margin-right:20px;
}
.breakout{
border-radius: 25px;
  border: 2px solid #c00c00;
  padding: 20px;
}

</style>
<article id="post-89552" class="post-89552 post type-post status-publish format-standard hentry category-opinion">
		<header class="entry-header clearfix"><h1 class="entry-title">Rick Houser: They have never liked me</h1><div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.clermontsun.com/2021/04">April 15, 2021</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.clermontsun.com/author/administrator">Administrator</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.clermontsun.com/category/opinion" rel="category tag">Opinion</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.clermontsun.com/2021/04/15/rick-houser-they-have-never-liked-me#respond" class="mh-comment-count-link" ><span class="dsq-postid" data-dsqidentifier="89552 https://www.clermontsun.com/?p=89552">0</span></a></span>
</div>
				
			</header>
		<div class="entry-content clearfix">
																				<div class="mh-social-top">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.clermontsun.com%2F2021%2F04%2F15%2Frick-houser-they-have-never-liked-me&t=Rick+Houser%3A+They+have+never+liked+me', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Rick+Houser%3A+They+have+never+liked+me:&url=https%3A%2F%2Fwww.clermontsun.com%2F2021%2F04%2F15%2Frick-houser-they-have-never-liked-me', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.clermontsun.com%2F2021%2F04%2F15%2Frick-houser-they-have-never-liked-me&media=&description=Rick+Houser%3A+They+have+never+liked+me', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.clermontsun.com%2F2021%2F04%2F15%2Frick-houser-they-have-never-liked-me', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Rick%20Houser%3A%20They%20have%20never%20liked%20me&amp;body=https%3A%2F%2Fwww.clermontsun.com%2F2021%2F04%2F15%2Frick-houser-they-have-never-liked-me" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>
																		
																						<div class="extraBox">
														</div>
										<p>I have always stated just how much I loved growing up a farm boy and living out in the country. I have felt that John Denver’s song “Thank God I’m a Country Boy” was my theme song. Now that spring has arrived and the climate is much warmer I have seen, flying around me a reminder that all on the farm is not kinda laid back. I have seen a couple of bees. Need I say more? <figure id="attachment_79732" aria-describedby="caption-attachment-79732" style="width: 300px" class="wp-caption alignright"><a href="https://s25452.pcdn.co/wp-content/uploads/2018/03/Houserjpg.jpg"><img src="https://s25452.pcdn.co/wp-content/uploads/2018/03/Houserjpg-300x214.jpg" alt="" width="300" height="214" class="size-medium wp-image-79732" srcset="https://s25452.pcdn.co/wp-content/uploads/2018/03/Houserjpg-300x214.jpg 300w, https://s25452.pcdn.co/wp-content/uploads/2018/03/Houserjpg.jpg 504w" sizes="(max-width: 300px) 100vw, 300px" /></a><figcaption id="caption-attachment-79732" class="wp-caption-text">Clermont County&#8217;s Rick Houser has released a second book, this one titled &#8220;Memories from the Heart.&#8221;</figcaption></figure></p>
<p>When you work around old out buildings and especially barns, you are going to run into your share of this insect. In the barns are bumblebees and they can be huge in size or small yet can pack a mighty sting. I know this as I have run into both kinds personally. If you do not find the bees, you will run into a wasp nest and they not only sting hard but also will sting repeatedly where at least a bee can only sting you one time as they lose their stinger. Either way just is in no way a pleasant event in my view of country life. </p>
<p>As the summers passed and each summer, I would get stung once or often I eventually became allergic to the stings. I swell and these days it is important to keep a bottle of Benadryl and a trip to the ER for a shot. Therefore, it is a topic I feel could be left out of farm life and a good memory. These days I try very hard to search them out before I step into a mess of them (oh by the way if available make a poultce out of cigarette tobacco and place it over the sting. It will draw the venom .Fact!) It is said that bees and wasps can tell if you fear them and they will attack you. I know my dad was never bothered by them and he wasn’t worried about them as he would kill them with some gasoline as he could get that close to them without them attacking where if it was me they came after me before I ever entered the barn. </p>
<p>Over the years I have learned and been taught lessons about this painful foe. In addition,I seem to be able to side step them. However when they are placed right where you must go just what can be done. When I was about ten to twelve years of age a man from Moscow named Al Kappas, ask dad if he could place some of his honeybee hives on our farm so they could pollenate our crops and make honey in the process. Al was a really nice person, dad liked him, and the idea of helping pollenate the crops seemed to register with dad as a good idea. Now dad owned two hundred acres and that is a lot of room to set up beehives but dad decided that it would be easier for Al if he were to place them under the pine trees right along the road. This was so Al could stop his car and get to the bees quickly. So Mr. Kappas placed three hives under the trees but right beside the field and a gate to another field. </p>
<p>To begin with there was really no notice that a honeybee was on our farm. That was until dad sent me over to the first field to cut the hay with a mowing machine. A tractor has a steady hum to it and the mowing machine has a steady clacking sound. Together I learned that day that the two sounds were not to the honey bees liking. To mow I started by mowing around the entire field. All was good and I was just getting settled in to the job when I neared the hives and out of what seemed like nowhere I was attacked and stung several times before I could get the tractor on down the field and abandoned the job. I went to the house, found dad, showed, and told him about the attack. So he walks over to the tractor, climbs on, goes up, and mows a good amount of hay near the bees. Did they bother him? No, they sure did not. </p>
<p>After he cleared a section away from them, he brought the tractor back to me and told me they could sense I was afraid of them and that was the reason I got stung. After the explanation, I still was not very happy about the whole thing. I ask dad if he could get Al to move them elsewhere and dad said it seemed they were all settled in there now. Folks I did not see it that way at all. I sure was not settled in. In the fall, Mr. Kappas took the homey from the hives and he paid dad for letting him put his hives there with two quarts of pure honey and one even had some of the comb in it and that is good stuff to put it mildly. So that fall and winter and summer, I was ok with their location. I kept a mental not as to where the hives were and that was just where I was not going to be. </p>
<p>Over the next couple of years, the bees went about their business and we went about ours. I just gave them more distance. In addition, each fall we were paid in some of the best honey I have ever tasted. I need to explain that when the beekeeper takes the honey from the hives the bees are very upset about being robbed and it really does not take anything to stir them up and put them on the attack mode. The following spring Al placed more hives beside the others and now there were seven hives all in a row. The way I saw it looked to me was that was murder’s row. </p>
<p>Since we farmed where we rotated our crops on a five-year rotation, it was time to plant corn in the field on the other side of the gate. I decided to not even try to go through the gate but instead I went up to the other side of the field and cut a new entry into the field. The only issue would be to run machinery on the corner of the field where the hives were. However, as I would have to do some work near that gate all remained calm. So I went through planting and growing season without a problem and began to become complacent with the bees. </p>
<p>That was until it was time to pick the corn. Since it was in the fall of the year and the bees had just had their honey robbed they returned to not liking me. So confident was I that I drove a load of corn through the gate and just as I went through it, I was swarmed. I put the tractor into high gear and as we went as fast as I could make it go and ears of corn bouncing off the wagon I was chewing myself out for forgetting. I needed to pick the corn near the gate(and did it after dark.) and remembered that bees stay away from smoke so I would light a cigarette every time I passed that corner. Here was probably the only time smoking was good for my health. The only good thing about that year was since more hives we were paid in four quarts of honey. I sure felt that I earned my share of the honey for sure. </p>
<p><em>Rick Houser grew up on a farm near Moscow in Clermont County and loves to share stories about his youth and other topics. If you are interested in reading more of his stories they can be found in his books ‘There are Places to Remember” and’ Memories ARE from the Heart.&#8221; He may be reached at <a href="mailto:houser734@yahoo.com">houser734@yahoo.com</a> or mail to P.O. Box 213 Bethel, Ohio 45106.</em></p>
										<div class="mh-social-bottom">
<div class="mh-share-buttons clearfix">
	<a class="mh-facebook" href="#" onclick="window.open('https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.clermontsun.com%2F2021%2F04%2F15%2Frick-houser-they-have-never-liked-me&t=Rick+Houser%3A+They+have+never+liked+me', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
		<span class="mh-share-button"><i class="fa fa-facebook"></i></span>
	</a>
	<a class="mh-twitter" href="#" onclick="window.open('https://twitter.com/share?text=Rick+Houser%3A+They+have+never+liked+me:&url=https%3A%2F%2Fwww.clermontsun.com%2F2021%2F04%2F15%2Frick-houser-they-have-never-liked-me', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
		<span class="mh-share-button"><i class="fa fa-twitter"></i></span>
	</a>
	<a class="mh-pinterest" href="#" onclick="window.open('https://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.clermontsun.com%2F2021%2F04%2F15%2Frick-houser-they-have-never-liked-me&media=&description=Rick+Houser%3A+They+have+never+liked+me', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
		<span class="mh-share-button"><i class="fa fa-pinterest"></i></span>
	</a>
	<a class="mh-googleplus" href="#" onclick="window.open('https://plusone.google.com/_/+1/confirm?hl=en-US&url=https%3A%2F%2Fwww.clermontsun.com%2F2021%2F04%2F15%2Frick-houser-they-have-never-liked-me', 'googleShare', 'width=626,height=436'); return false;" title="Share on Google+" target="_blank">
		<span class="mh-share-button"><i class="fa fa-google-plus"></i></span>
	</a>
	<a class="mh-email" href="mailto:?subject=Rick%20Houser%3A%20They%20have%20never%20liked%20me&amp;body=https%3A%2F%2Fwww.clermontsun.com%2F2021%2F04%2F15%2Frick-houser-they-have-never-liked-me" title="Send this article to a friend" target="_blank">
		<span class="mh-share-button"><i class="fa fa-envelope-o"></i></span>
	</a>
</div></div>

	</div></article>
<nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.clermontsun.com/2021/04/15/george-rooks-the-pretty-baby-ducks" rel="prev"><span>Previous</span><p>George Rooks: The pretty baby ducks</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://www.clermontsun.com/2021/04/15/marc-hoover-the-disappearances-of-felipe-santos-and-terrance-williams" rel="next"><span>Next</span><p>Marc Hoover: The disappearances of Felipe Santos and Terrance Williams</p></a></div>
</nav>
				<div id="rc-widget-190863" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="168424"></div>
				<script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
				<a id="comments"></a>
				
<div id="disqus_thread"></div>
			<!-- Champion Media; TVX InContent -->
<div style="min-width: 300px;width: 100%">
	<div id="ahm-vidya-2" style="display: inline-block; vertical-align: top;width: calc( 100% - 310px ); min-width: 300px;"></div>
	<script>
		var cbuster = Date.now();
		var puburl = encodeURIComponent( document.location.href );
		var placeId = "104508"; //placement/site
		var templateId = "7898"; //player
		var contentId = "plembed20aclxijwhmt"; //playlist
		var sURL = "https://live.sekindo.com/live/liveView.php?s=" + placeId + "&cbuster=" + cbuster + "&pubUrl=" + puburl + "&subId=[SUBID_ENCODED]&x=300&y=250&vp_content=" + contentId + "t&vp_template=" + templateId;
		var d = document;
		var s = "script";
		var sParent = d.querySelector("#ahm-vidya-2");
		var sPlayer = d.createElement(s);
			sPlayer.async = true;
			sPlayer.src = sURL;
			
			sParent.appendChild( sPlayer );
	</script>
	<div style="display: inline-block; margin: 0 5px 0 0;"><div style="vertical-align: top;width: 300px; min-height: 50px;" id="_snup-tvx-ldgr1"></div></div>
</div>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5JSJKTT');</script><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5JSJKTT"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="custom_html-9" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="255" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>--->
</div></div><div id="custom_html-10" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Weather</span></h4><div class="textwidget custom-html-widget"><div style="width: 300px;"><iframe style="display: block;" src="https://cdnres.willyweather.com/widget/loadView.html?id=81685" width="300" height="228" frameborder="0" scrolling="no"></iframe><a style="margin: -20px 0 0 0;display: block;position: relative;height: 20px;text-indent: -9999em;z-index: 1" href="https://www.willyweather.com/oh/clermont-county/batavia.html" rel="nofollow">batavia OH weather forecast</a></div></div></div><div id="custom_html-17" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- Champion Media Ad Server Asynchronous JS Tag - Generated with Revive Adserver v5.0.4 -->
<ins data-revive-zoneid="254" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>
<script async src="//championads.midtc.com/www/delivery/asyncjs.php"></script></div></div><div id="custom_html-11" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="256" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>---></div></div><div id="custom_html-19" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Recipes</span></h4><div class="textwidget custom-html-widget"><!-- Champion Media (Id #10190); Right Rail TRX -->
<div id="_snup-target1"></div><div id="_snup-dug-ldgr0"></div><script src="https://japfg-trending-content.appspot.com/widgey-dug.php?s=10190&v=1&q=3&i=1"></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer','GTM-5JSJKTT');</script><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5JSJKTT" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript></div></div><div id="custom_html-26" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="https://embed.secondstreetapp.com/Scripts/dist/optin.js" data-ss-embed="optin" data-design-id="2290300"></script></div></div><div id="custom_html-12" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="257" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>---></div></div><div id="custom_html-14" class="widget_text mh-widget widget_custom_html"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Advertisement</span></h4><div class="textwidget custom-html-widget"><!---<ins data-revive-zoneid="258" data-revive-id="536abf87d1f56ff662219619e5b36223"></ins>---></div></div>	</aside>	</div>
    </div>
<footer class="mh-footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter">
<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-1">
<div id="media_image-2" class="mh-footer-widget widget_media_image"><a href="http://championcarolinas.com"><img width="300" height="81" src="https://s25452.pcdn.co/wp-content/uploads/2018/02/championwhite-300x81.png" class="image wp-image-79653  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" /></a></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-2">
<div id="nav_menu-2" class="mh-footer-widget widget_nav_menu"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">General Information</span></h6><div class="menu-footer-nav-container"><ul id="menu-footer-nav" class="menu"><li id="menu-item-79658" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-79658"><a href="https://www.clermontsun.com/terms-of-service">Terms of Service</a></li>
<li id="menu-item-79657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-79657"><a href="https://www.clermontsun.com/privacy-policy">Privacy Policy</a></li>
</ul></div></div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-3">
		<div id="recent-posts-3" class="mh-footer-widget widget_recent_entries">		<h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Recent Articles</span></h6>		<ul>
											<li>
					<a href="https://www.clermontsun.com/2021/04/15/jennifer-lake-low-income-older-adults-need-access-to-fresh-produce-farmers-market-program-provides-it">Jennifer Lake: Low-income older adults need access to fresh produce; farmers’ market program provides it</a>
									</li>
											<li>
					<a href="https://www.clermontsun.com/2021/04/15/john-plahovinsak-surveys-prove-vas-quality-medical-health-care-improves">John Plahovinsak: Surveys prove VA’s quality medical health care improves</a>
									</li>
											<li>
					<a href="https://www.clermontsun.com/2021/04/15/sen-sherrod-brown-allowing-more-ohio-workers-to-earn-overtime-pay">Sen. Sherrod Brown: Allowing more Ohio workers to earn overtime pay</a>
									</li>
											<li>
					<a href="https://www.clermontsun.com/2021/04/15/sen-rob-portman-stopping-the-crisis-at-the-border">Sen. Rob Portman: Stopping the crisis at the border</a>
									</li>
											<li>
					<a href="https://www.clermontsun.com/2021/04/15/marc-hoover-the-disappearances-of-felipe-santos-and-terrance-williams">Marc Hoover: The disappearances of Felipe Santos and Terrance Williams</a>
									</li>
					</ul>
		</div></div>
<div class="mh-col-1-4 mh-widget-col-1 mh-footer-4-cols  mh-footer-area mh-footer-4">
<div id="text-6" class="mh-footer-widget widget_text"><h6 class="mh-widget-title mh-footer-widget-title"><span class="mh-widget-title-inner mh-footer-widget-title-inner">Contact</span></h6>			<div class="textwidget"><p><strong>Visit:<br />
</strong>465 East Main Street<br />
Batavia, Ohio 45103<br />
<strong>Call:</strong><br />
T:513.732.2511<br />
F:513.732.6344<br />
<strong>E-mail:</strong><br />
info@clermontsun.com</p>
</div>
		</div><div id="custom_html-21" class="widget_text mh-footer-widget widget_custom_html"><div class="textwidget custom-html-widget"><script src="//championads.midtc.com/www/delivery/asyncjs.php"></script></div></div></div>
</div>
</footer>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">
			2018 Champion Media		</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-130134541-2"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-130134541-2');
</script>
<script>if(window.addEventListener){ window.addEventListener('load', function(){ printCornerAd({alignTo:'tl', mirror:true, colorIn:'#FFFFFF', thumbPath:'https://s25452.pcdn.co/wp-content/uploads/2021/03/3NEMW0O-Smallleft-100x100.png', imgPath:'https://s25452.pcdn.co/wp-content/uploads/2021/03/3NEMW0O-LGleft-500x500.png', adUrl:'https://maysville-online.com/wp-content/uploads/2021/03/Rod-Rumb-2021-3.15.21.png', openIn:-1, closeIn:-1, target:'_blank'}); }); }else{ window.attachEvent('onload', function(){ printCornerAd({alignTo:'tl', mirror:true, colorIn:'#FFFFFF', thumbPath:'https://s25452.pcdn.co/wp-content/uploads/2021/03/3NEMW0O-Smallleft-100x100.png', imgPath:'https://s25452.pcdn.co/wp-content/uploads/2021/03/3NEMW0O-LGleft-500x500.png', adUrl:'https://maysville-online.com/wp-content/uploads/2021/03/Rod-Rumb-2021-3.15.21.png', openIn:-1, closeIn:-1, target:'_blank'}); }); } </script><script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"clermont-sun"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s25452.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.21'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.21"},"disqusIdentifier":"89552 https:\/\/www.clermontsun.com\/?p=89552","disqusShortname":"clermont-sun","disqusTitle":"Rick Houser: They have never liked me","disqusUrl":"https:\/\/www.clermontsun.com\/2021\/04\/15\/rick-houser-they-have-never-liked-me","postId":"89552"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s25452.pcdn.co/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.21'></script>
<script type='text/javascript' src='https://s25452.pcdn.co/wp-includes/js/comment-reply.min.js?ver=5.3.7'></script>
<script type='text/javascript' src='https://s25452.pcdn.co/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var megamenu = {"timeout":"300","interval":"100"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s25452.pcdn.co/wp-content/plugins/megamenu/js/maxmegamenu.js?ver=2.9.3'></script>
<script type='text/javascript' src='https://s25452.pcdn.co/wp-includes/js/wp-embed.min.js?ver=5.3.7'></script>
<script type='text/javascript' src='https://s25452.pcdn.co/wp-content/plugins/corner-ad/js/raphael-min.js?ver=5.3.7'></script>
<script type='text/javascript' src='https://s25452.pcdn.co/wp-content/plugins/corner-ad/js/cornerAd.min.js?ver=1.0.46'></script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"62f380209b","applicationID":"309219071","transactionName":"ZlNUNxdQWhZTWk0KWl8ZdwARWFsLHUpQDVJdUw==","queueTime":0,"applicationTime":141,"atts":"ShRXQV9KSRg=","errorBeacon":"bam-cell.nr-data.net","agent":""}</script></body>
</html>